Promedio ponderado con SUMAPRODUCTO

Lo puedes hacer con: Excel para Office 365, Excel 2019, Excel 2016, Excel 2013 y Excel 2010

Promedio ponderado con SUMAPRODUCTO

Supón que tienes una lista que muestra el número de personas por edad y deseas calcular la edad promedio, de todas las personas (promedio ponderado). Para obtener el resultado, seguro pensarás hacer varios cálculos intermedios.

En este artículo te enseño cómo calcular el promedio ponderado utilizando una sola fórmula con la función SUMAPRODUCTO.

Antes de enseñarte la fórmula quiero mostrarte, ya sea por si no sabes o no recuerdas, cómo sería el proceso «más largo» para calcular el promedio ponderado. Esto también servirá para que entiendas lo que hace la fórmula que te mostraré más adelante.

Para calcular el promedio ponderado debemos multiplicar cada edad por el número de personas, luego sumar todos los productos y dividirlos por la suma del número de personas.

Ejemplo del cálculo del promedio ponderado usando formulas.

Fórmula usando SUMAPRODUCTO

La función SUMAPRODUCTO nos permitirá hacer las dos primeras partes del cálculo, es decir, multiplicar cada edad por el número de personas y luego sumar todos los productos. Luego debemos dividir el resultado de la función por la suma del número de personas.

La fórmula que utilizaré en el ejemplo será:

=SUMAPRODUCTO(A2:A12;B2:B12)/SUMA(B2:B12)

Ejemplo de cálculo del promedio ponderado usando la función SUMAPRODUCTO.

Ahora ya sabes cómo calcular el promedio ponderado con la ayuda de la función SUMAPRODUCTO.


Si quieres aprender más sobre Excel, revisa estos artículos:

Encuentra valores duplicados usando el formato condicional

Obten una lista de valores únicos en Excel

Selecciona y completa celdas vacías o en blanco

Calcula la edad con Excel

Licencia Creative Commons

El texto e imágenes de este articulo cuyo autor es excelexplicado.com están bajo una licencia de Reconocimiento 4.0 Internacional de Creative Commons.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *